Обозначим через ТРЕУГ(n, m, k) утверждение «существует невырожденный треугольник с длинами сторон n, m и k».

Для какого наибольшего натурального числа А формула

¬((ТРЕУГ(х, 11, 18) ≡ (¬(MAKC(x, 5) > 68))) ⋀ ТРЕУГ(х, А, 5))

тождественно истинна (т. е. принимает значение 1) при любом натуральном значении переменной х?

Примечание. МАКС(а, b) = а, если а > b и МАКС(а, b) = b, если а ≤ b.

def treg(x,y,z):
    return max(x,y,z)<(x+y+z-max(x,y,z))
            
for A in range(1,100):
    flag=1
    for x in range(1,100):
        if (not((treg(x,11,18)==(not(max(x,5)>68))) and treg(x,A,5)))!=1:
            flag=0
    if flag==1:
        print(A)
